MetaTrader 5 Hilfe

Dateien und Ordner

Dieser Abschnitt beschreibt die Datei- und Ordnerstruktur der Plattform. Im Hauptmodus des Plattformstarts, werden modifizierte und schreibgeschützte Dateien separat gespeichert.

Schreibgeschützte Dateien der Plattform

Diese Dateien liegen in /Program Files/platform folder/. Das sind:

  • Terminal.exe — die ausführbare Datei der Plattform;
  • MetaEditor.exe — die ausführbare Datei des eingebauten MQL5 Language Editor;
  • Sounds/*.wav — Auswahl an Standard Audio-Dateien der Plattform;

Modifizierte Dateien

Das Installationsverzeichnis der Handelsplattform beinhaltet mehrere Ordner: Bases, Config, Logs, MQL5, Profiles, Templates, Tester. Für schnellen Zugriff nutzen Sie den Befehl "Datei-Ordner öffnen Datei-Ordner öffnen" im Datei-Menü.

Alle Text-Dateien werden im Unicode-Format gespeichert. Nutzen Sie die entsprechende Software zum Editieren.

Im Bases-Ordner werden die Datenbanken der Plattform nach Server sortiert gespeichert:

Ordner und Dateien

Beschreibung

Unterordner

Beschreibung

Default

Allgemeiner Ordner für Datenbanken

Historie

Der Ordner mit den historischen Datenbanken von Finanzinstrumenten. Jedes Instrument wird in einen separaten Ordner gespeichert im Format JJJJ.hcc ticks.dat und der Cache Ordner. Dateien JJJJ.hcc beinhalten Einminutendaten eines Symbols, der Dateiname reflektiert das Jahr zu dem die Daten gehören. Die Datei ticks.dat enthält Tickdaten des Symbols. Die Dateien *.hc gespeichert im "Cache" Ordner beinhaltet Kerzen von verschiedenen Zeitrahmen berechnetet aus den Einminutendaten. Diese werden automatisch kreiert, wenn die entsprechende Periode ausgewählt wird.

Mail

Der Ordner speichert alle E-Mails die gesendet oder empfangen wurden. Die E-Mail-Datenbank wird gespeichert in *.dat files; eine separate Datei für jedes Konto. Zum Beispiel, mail-xxxxx.dat, wobei xxxxx die Kontonummer ist.

 

Server 1 — N

Plattform Datenbank Order für verschiedene Handelsserver

News

Die Ordner speichern nur eine Datei news.dat die eine Datenbank aller Newsletter beinhalten die von der Plattform erhalten wurden.

Symbole

Die Datei selected-xxxxx.dat beinhaltet die Datenbank des aktuell ausgewählten Symbols in der Marktübersicht. Die Datei symbols-xxxxx.dat beinhaltet die standardmäßige Datenbank aller Symbole auf dem Handelsserver.

Trades

Beinhaltet Unterordner benannt nach den Konto-Nummern die in der Plattform verwendet wurden. Jeder Konto-Ordner beinhaltet deals_yyyy.mm.dat und history_yyyy.mm.dat mit den Informationen über Trades- und Order-Historie. Separate Dateien werden jeden Monat erstellt. Hier JJJJ meint das Jahr, und MM — Monat.

alerts.dat

Beinhaltet die Datenbank erschaffener Alarme.

books.dat

Beinhaltet eine Liste aktuell geöffneter Fenster.

favourites.dat

Beinhaltet eine Datenbank von Elementen in den Favoriten des Navigators.

gvariables.dat

Beinhaltet global Variablen die in der Plattform genutzt werden.

hotkeys.ini

Datenbank an Tastatur-Hotkeys.

indicators.dat

Beinhaltet Nutzungsstatistiken von Indikatoren zum Anzeigen im Einfügen-Menü.

objects.dat

Beinhaltet Nutzungsstatistiken zu Objekten zum Anzeigen im Einfügen-Menü.

Das Verzeichnis Config beinhaltet die Konfigurationsdateien:

Ordner und Dateien

Beschreibung

certificates

Ordner mit den Zertifikat-Dateien *.pfx

accounts.dat

Beinhaltet die Datenbank an Konten und der Einstellungen.

common.ini

Beinhaltet die allgemeinen Plattform-Einstellungen, verfügbar in den Optionen geöffnet mit dem Extras-Menü.

metaeditor.ini

Beinhaltet allgemeine Einstellungen des MetaEditor.

terminal.ini

Beinhaltet Plattform-Interface-Einstellungen und zuletzt genutzte Werte (Fenster-Positionierung, Indikatoren, etc.)

servers.dat

Handelsserver-Einstellungen für Verbindungen.

Die Log-Ordner beinhalten Log-Dateien der Plattform und des MetaEditor, sowie Crash Logs:

Ordner und Dateien

Beschreibung

/Crash/crash.log.*

Das Verzeichnis /crash beinhaltet Dateien von Plattform Crashes. Diese Dateien werden automatisch an den Entwickler gesendet um die Fehler zu beheben.

JJJJMMTT.log

Log-Dateien beinhalten Informationen über Events in der Plattform. Plattform-Logs werden gespeichert in separaten Dateien für jeden Tag. Hier steht JJJJ für das Jahr, MM — Monat, TT — Tag.

metaeditor.log

MetaEditor Log-Dateien.

Das MQL5 Verzeichnis beinhaltet Informationen zu MQL5 Programmen:

Ordner und Dateien

Beschreibung

/Experts

Beinhaltet Expert Advisor, kompilierte Dateien (*.ex5) und Quellcode-Dateien (*.mq5).

/Files

Beinhaltet Dateien die von Expert Advisor und Skripten genutzt werden.

/Images

Beinhaltet Bild-Dateien im *.bmp Format.

/Include

Beinhaltet allgemeine *.mqh Include-Dateien.

/Indicators

Beinhaltet Dateien Indicatoren.Con

/Libraries

Beinhaltet MQL5 Bibliotheken.

/Logs

Beinhaltet Expert Advisor Log-Dateien (JJJJMMTT.log). Diese Dateien werden erschaffen für jeden Tag der Expert Advisor Nutzung, die Namen korrespondieren mit dem Erstellungsdatum: JJJJ steht für das Jahr, MM Monat, TT Datum.

/Presets

Parameter von Expert Advisors werden im Ordner ("Eingabeparameter") gespeichert.

/Profiles

Beinhaltet verschiedene Profile und Vorlagen:

  • /Charts — Profile von Charts. Im Unterverzeichnis "Default" werden die Vorlagen der standardmäßigen Einstellungen von Charts gespeichert. Benutzerdefinierte und eingebaute Profile werden in separaten Unterverzeichnissen gespeichert, deren Namen den Namen dieser Profile entsprechen. Jedes Profil beinhaltet *.chr-Dateien mit der Beschreibung von Charts und die order.wnd-Datei, in welcher die Reihenfolge der Fenster gespeichert wird.
  • /Deleted — Vorlagen gelöschter Charts für die anschließende Wiedereröffnung.
  • /SymbolSets — Sets von Symbolen (inkl. angezeigte Informationsspalten) für das Fenster "Marktübersicht".
  • /Templates — Vorlagen von Charts als *.tpl-Dateien sowie HTML-Vorlagen für Berichte:
  • /Tester — *.set Dateien mit den zuletzt verwendeten Sets von Eingabeparametern für jeden Expert Advisor, der mindestens einmal getestet wurde.

/Scripts

Beinhaltet Dateien von Skripts.

experts.dat

Beinhaltet Nutzungsstatistiken von MQL5 Programmen zum Anzeigen im Einfügen-Menü.

Das Tester-Verzeichnis beinhaltet Dateien und Ordner genutzt vom Strategietester:

Ordner und Dateien

Beschreibung

Unterordner

Beschreibung

Agent-IP-address-port

Diese Ordner werden für jeden Agenten erstellt. Der Ordner-Name enthält die IP-Adresse und Portnummer des Agenten

MQL5

Der zuletzt getestete Expert Advisor wird in diesem Ordner gespeichert. Expert Advisor werden nicht gespeichert im Ordner der Remote Agenten.

logs

Die Einträge der Agenten Journale werden in diesem Ordner gespeichert.

bases

Historische Daten, die vom Agenten genutzt werden, werden in diesem Ordner gespeichert.

logs

Dieser Ordner enthält Strategietester Log-Dateien (JJJJMMTT.log). Diese Datei wird für jeden Tag der Expert Advisor Nutzung erstellt, die Namen korrespondieren mit dem Erstellungsdatum: JJJJ Jahr, MM Monat, TT Tag.

/Manager

Dieses Verzeichnis enthält die Log-Einträge der MetaTester Komponenten.

/Cache

Dieser Ordner beinhaltet die XML-Dateien aus dem Cache der letzten Expert Advisor Optimierung.