MetaEditor Hilfe

Beispiel einer Programmentwicklung

Beispiel einer Programmentwicklung

Dank dem MQL4/MQL5 Assistenten benötigen Sie nur ein paar Minuten, um ein einfaches Programm zu erstellen. Das aktuelle Beispiel zeigt "Hello World" in das Loog der Plattform.

Starten Sie den MQL4/MQL5 Assistenten mit dem Befehl Neu Neu im Menü Datei oder in der standardmäßigen Symbolleiste. Verwenden Sie Skript als Programmtyp im ersten Schritt.

Erstellen eines Skriptes mit dem Assistenten

Danach bestimmen Sie den Namen des Skriptes. Wenn Sie die Skriptdatei in einem separaten Unterordner und nicht im Stammverzeichnis von Scripts erstellen möchten, fügen Sie den Ordnernamen in das Feld Name ein. Zum Beispiel, "Scripts\Script Beispiel\Script Beispiel". Nachdem Sie auf Fertig stellen geklickt haben, wird die Skriptdatei "Script Example.mq5" im Verzeichnis "Scripts\Script Example\" erstellt.

Fügen Sie die Zeichen "Print("Hello World!);" in die neue Datei ein und speichern Sie die Änderungen (Strg+S). Kompilieren Sie jetzt, damit aus der ursprünglichen Datei eine auf der Handelsplattform ausführbare Datei erzeugt wird. Tippen Sie auf Kompilieren Kompilieren im Menü Datei oder in der Symbolleiste. Das Ergebnis des Kompilierens wird im Reiter Fehler des Fensters der Toolbox angezeigt:

Skript-Kompilierung

Als Ergebnis der Kompilierung wird die ausführbare Scriptdatei ScriptExample.ex5 im gleichen Verzeichnis erstellt, in dem sich die Quelldatei befindet.

Das Debuggen ermöglicht es Ihnen, die Ausführung eines Programms in Einzelschritten zu überprüfen. Setzen Sie ggf. Haltepunkte – Befehlszeilen/Funktionen, bei denen die Programmausführung angehalten wird. Machen Sie einen Doppelklick dazu die linke Maustaste links neben der gewünschten Zeile. Klicken Sie dann auf Debugging beginnen Debugging beginnen im Menü Debug oder in der Symbolleiste.

Debugging starten

Das Skript wird auf einem temporären Chart in der Handelsplattform gestartet, und das Skript schreibt – "Hello World!" in das Log des Experten:

Debuggen des Skripts

Um das Debugging zu beenden, drücken Sie Beenden Beenden.

Nach Abschluss aller Schritte können Sie das Skript auf der Handelsplattform ausführen. Um es zu öffnen, klicken Sie auf MetaTrader öffnen Handelsterminal im Menü Extras oder F4.