MetaEditorヘルプ

プログラムの開発例

プログラムの開発例

MQL4/MQL5ウィザードのおかげで、数分で簡単なプログラムを作成することができます。 現在のサンプルでは、プラットフォームログに "Hello World " というエントリが表示されます。

MQL4/MQL5ウィザードを起動します。新規ファイルメニューまたは標準ツールバーの新しいコマンド。 最初のステップでスクリプトをプログラムタイプとして設定します。

ウィザードでのスクリプトの作成

次に、スクリプト名を設定します。 スクリプトファイルをスクリプトルートディレクトリではなく別のサブフォルダに作成する場合は、[名前] フィールドにフォルダ名を追加します。 たとえば、 "Scripts\Script Example\Script Example" [完了] をクリックすると、 "Script Example.mq5 " スクリプトファイルが "Scripts\Script Example" ディレクトリに生成されます。

生成されたファイルに "Print ("Hello World!"); " の文字列を追加し、変更を保存します (Ctrl + S)。 コンパイルを実行して、最初のファイルをトレーディングプラットフォームで起動できるものに変換します。 利用できるオプションを一覧にするには、コンパイルします。ファイルメニューまたはツールバーのコンパイル コンパイル結果は、[ツールボックス] ウィンドウの[エラー ] タブに表示されます。

スクリプトのコンパイル

コンパイルの結果として、ScriptExample.ex5の実行可能スクリプトファイルがソースファイルが置かれているのと同じディレクトリに作成されます。

デバッグモードでは、プログラムの実行を確認できます。 必要に応じて、ブレークポイント (プログラムの実行が一時ストップされる文字列/関数)を設定します。 これを行うには、必要な行の左にマウスの左ボタンをダブルクリックします。 クリックして "デバッグを開始するDebugメニューまたはツールバーで.デバッグを開始します。

デバッグの起動

スクリプトはトレーディングプラットフォームの一時チャートで起動され、スクリプト操作の結果—"Hello World!"エントリエキスパートログに表示されます。

スクリプトのデバッグ

デバッグを終了するには、 "デバッグのストップデバッグをストップします "。

すべての手順を完了した後、トレーディングプラットフォームでスクリプトを実行することができます。 クリックして開くには、トレーディングターミナルツールメニューのトレーディングターミナルまたは F4