Aide MetaEditor

Exemple de Création d'un Programme

Exemple de Création d'un Programme

Un exemple de création d'un script simple en utilisant MetaEditor est décrit pas à pas dans cette section.

Création du Programme à l'aide d'un Modèle

Il est nécessaire de démarrer l'Assistant MQL4/MQL5 en exécutant la commande "Nouveau Nouveau" du menu "Fichier" ou de la barre d'outils "Standard".

Création du Script à l'aide de l'Assistant

Vous devez ensuite choisir l'option "Script" et appuyer sur le bouton "Suivant".

Spécification des Paramètres du Script

Vous devez ensuite spécifier le nom du script et les informations concernant son auteur et l'adresse de son site Internet. Le nouveau fichier du script est créé dans le répertoire "Scripts" lorsque le bouton "Terminer" est appuyé. Il est, en outre, nécessaire de créer un dossier séparé pour le script. Vous devez pour ce faire exécuter la commande "Nouveau Dossier" depuis le menu contextuel de la fenêtre "Navigateur".

Création du Dossier

L'étape suivante consiste à déplacer le fichier créé pour le script (ScriptExample.mq5) vers le nouveau dossier en le glissant directement depuis la fenêtre "Navigateur". Lorsque le fichier sera déplacé, vous pourrez commencer à écrire du code source :

Écriture du Code Source

Une fois le code source écrit, il est nécessaire de le sauver et de le compiler en utilisant les commandes "Sauvegarder Sauvegarder" et "Compiler Compiler" du menu "Fichier" ou de la barre d'outils "Standard". Le résultat de la compilation sera affiché dans l'onglet "Erreurs" de la fenêtre "Boîte à Outils" :

Compilation du Script

Le fichier exécutable du script ScriptExample.ex5 sera créé si la compilation est réussie, il sera alors placé dans le même répertoire que le fichier source.

Vous pouvez alors déboguer le script si cela est nécessaire. Vous devez pour ce faire placer un point d'arrêt sur la ligne désirée en double cliquant sur la zone grise située sur la gauche de la ligne. Il faut ensuite exécuter la commande "Commencer le Débogage Commencer le Débogage" du menu "Déboguer" :

Commencer le Débogage

Le script sera alors attaché au graphique temporaire du terminal client, et le résultat de l'exécution du script sera affiché dans le journal – l'inscription "Hello World!!!" :

Débogage du Script

Pour terminer le débogage, exécutez la commande "Arrêter le Débogage Arrêter le Débogage" du menu "Déboguer".

Lorsque toutes les étapes nécessaires sont passées avec succès, le script peut être utilisé dans le terminal client. Pour l'ouvrir, exécutez la commande "Trading Terminal Trading Terminal" du menu "Outils" ou appuyez sur la touche "F4".