MetaEditor 帮助

程序创建示例

程序创建示例

在这部分,将会一步一步描述使用MetaEditor创建简单脚本的示例。

通过模板创建程序

需要启动MQL向导 通过执行"新建 新建" 命令在"文件" 菜单或在"标准" 工具栏。

通过向导创建脚本

之后,应该选择“脚本”选项,按“下一步”按钮。

脚本参数规格

在这个步骤,应该指定脚本的名称和它作者的有关信息和网站地址。一旦按下“完成”按钮,在“Scripts”文件夹中将创建新的脚本文件。此外,还需要为脚本创建一个单独的文件夹。要做到这一点,应该在“导航”窗口的快捷菜单中执行“新建文件夹”命令。

创建文件夹

下一步是要移动创建的脚本文件(ScriptExample.mq5)到新文件夹,使用拖拽技术。 文件只要移动完成,就可以开始编写源代码:

源代码的编写

只要编写源代码,那么就需要保存和编译它使用"保存保存" 和 "编译 编译" 在"文件" 菜单或在"标准" 工具栏。编译的结果将显示在“工具箱”窗口的"错误" 标签:

脚本编译

作为编译的结果,脚本的可执行文件ScriptExampe.ex5也将被创建,它将被放置在与源文件同样的文件夹。

如果需要的话,可以调试脚本。做到这一点,应该双击位于线左边的灰色区域,放置断点在必要的线上。那么就需要执行"开始调试 开始调试" 命令在"调试" 菜单:

开始调试

一旦完成,那么脚本将会附加到客户端的临时图表,执行脚本的结果将显示在日志 ― "Hello World!!!" 字样:

调试脚本

要结束调试,应该执行"停止调试 停止调试" 命令在"调试" 菜单。

通过所有必要的步骤以后,脚本可用于客户端。要打开它,应该执行"交易程序端 交易程序端" 命令在"工具"菜单或使用 "F4" 键。