Справка по MetaEditor

Пример создания приложения

Пример создания приложения

В данном разделе по шагам будет рассмотрен пример создания простейшего скрипта с помощью MetaEditor.

Создание приложения по шаблону

Необходимо запустить "Мастер MQL4/MQL5", выполнив команду "Создать Создать" в меню "Файл" или на панели инструментов "Стандартная".

Создание скрипта в мастере

После этого необходимо выбрать пункт "Скрипт" и нажать кнопку "Далее".

Указание параметров скрипта

На данном этапе необходимо указать название скрипта, а также информацию об авторе и интернет адрес. После нажатия кнопки "Готово" будет создан новый файл скрипта в папке "Scripts". Далее следует создать отдельную папку для скрипта. Для этого нужно выполнить команду "Новая папка" контекстного меню окна "Навигатор".

Создание папки

Следующим шагом необходимо переместить созданный файл скрипта (ScriptExample.mq5) в новую папку, используя технологию Drag'n'Drop. После того как файл размещен, можно приступать к написанию кода:

Написание кода

После написания кода, необходимо его сохранить и скомпилировать, нажав кнопки "Сохранить Сохранить" и "Компилировать Компилировать" в меню "Файл" или на панели инструментов "Стандартная". Результат компиляции будет отображен на вкладке "Ошибки" окна "Инструменты":

Компиляция скрипта

Также в результате компиляции будет создан исполняемый файл скрипта ScriptExampe.ex5, который будет помещен в ту же папку, что и исходный файл.

При необходимости можно приступить к отладке скрипта. Для этого следует установить точку останова, дважды щелкнув левой кнопкой мыши на сером поле слева от необходимой строки. Далее нужно выполнить команду "Начать отладку Начать отладку" в меню "Отладка":

Запуск отладки

После этого скрипт будет наложен на временный график в торговом терминале, а в журнале экспертов появится результат работы скрипта — надпись "Hello World!!!":

Отладка скрипта

Для завершения отладки необходимо выполнить команду "Остановить отладку Остановить отладку" в меню "Отладка".

После того как все необходимые шаги пройдены, можно использовать скрипт в торговом терминале. Чтобы открыть его, необходимо выполнить команду "Торговый терминал Торговый терминал" в меню "Сервис" или нажать клавишу "F4".