Ajuda para o MetaEditor

Exemplo de Criação de Programa

Exemplo de Criação de Programa

Um exemplo de criação de um simples script usando o MetaEditor será descrito passo a passo nesta seção.

Criação de um Programa a partir de um Template

É necessário iniciar o Assistente MQL4/MQL5 executando o comando "Novo Novo" do menu "Arquivo" ou da barra de ferramentas "Padrão".

Criação de Script Via Assistente

Depois disso, deve-se escolher a opção "script" e pressionar o botão "Avançar".

Especificação de Parâmetros do Script

Nesta fase, deve-se especificar o nome do script e as informações sobre o seu autor e o endereço do site. Uma vez que o botão "Concluído" for pressionado, o novo arquivo do script será criado na pasta "Scripts". Além disso, é necessário criar uma pasta separada para o script. Para isso, deve-se executar o comando "Nova Pasta" do menu contextual da janela "Navegador".

Criação de Pasta

O próximo passo é mover o arquivo do script criado (ScriptExemplo.mq5) para a nova pasta usando a tecnologia Arrastar e Soltar. Pode-se começar a escrever o código-fonte assim que o arquivo for movido:

Escrever Código-Fonte

Assim que o código fonte for escrito, é necessário salvá-lo e compilá-lo usando o "SalvarSalvar" e "Compilar Compilar" do menu "Arquivo" ou da barra de ferramentas "Padrão". O resultado da compilação será mostrado na guia "Erros" da janela "Caixa de Ferramentas":

Compilação de Script

O arquivo executável do script ScriptExemplo.ex5 será criado como resultado da compilação, bem como ele será colocado na mesma pasta do arquivo de origem.

Pode-se depurar o script, se for necessário. A fim de fazê-lo, deve-se colocar uma ruptura na linha desejada com um duplo clique sobre o campo cinza localizado na esquerda da linha. Em seguida, é necessário executar o comando "Iniciar Depuração Iniciar Depuração" do menu "Depurar":

Iniciar Depuração

Assim que isso for feito, o script será anexado em um gráfico temporário no terminal cliente, e o resultado da execução do script será exibido no diário - a inscrição "Olá Mundo!!!":

Depuração de Script

Para terminar a depuração, deve-se executar o comando "Parar Depuração Parar Depuração" do menu "Depurar".

Assim que todas as etapas necessárias são passadas, o script pode ser utilizado no terminal cliente. Para abri-lo, deve-se executar o comando "Terminal de Negociação Terminal de Negociação" do menu "Ferramentas" ou usar a tecla "F4".