Ayuda de MetaEditor

Ejemplo de creación de una aplicación

Ejemplo de creación de una aplicación

En este apartado vamos a ver paso a paso cómo se crea el script más sencillo a través del MetaEditor.

Crear aplicación a base de plantilla

Inicie el "Asistente para MQL4/MQL5" utilizando el comando "Crear Crear" en el menú "Archivo" o en la barra de herramientas "Estándar".

Crear un script en el Asistente

Luego seleccione la opción "Script" y haga clic en el botón "Siguiente".

Indicar los parámetros del script

En este paso tiene que especificar el nombre del script e indicar la información sobre su autor y la dirección en Internet. En cuanto pulse en el botón "Finalizar", se creará un nuevo archivo del script en la carpeta "Scripts". Después, debe crear una carpeta individual para el script. Para eso debe ejecutar el comando "Nueva carpeta" en el menú contextual del "Navegador".

Crear carpeta

En el siguiente paso hay que mover el archivo del script que se ha creado (ScriptExample.mq5) en nueva carpeta, utilizando la tecnología Drag'n'Drop. Una vez ubicado el archivo, puede empezar a escribir el código:

Escribir el código

Después de escribir el código, tiene que guardar y compilarlo utilizando los botones "Guardar Guardar" y "Compilar Compilar" en el menú "Archivo" o en la barra de herramientas "Estándar". El resultado de la compilación estará disponible en la pestaña "Errores" de la ventana "Caja de herramientas":

Compilar el script

Como resultado de la compilación se creará el archivo de ejecución del script ScriptExampe.ex5 que será colocado en la misma carpeta donde se ubica el archivo con el código fuente.

Si hace falta, se puede depurar el script. Para eso hay que colocar el punto de interrupción, haciendo doble clic izquierdo en el campo gris a la izquierda de la línea necesaria. A continuación, ejecute el comando "Empezar depuración Empezar depuración" en el menú "Depurar":

Iniciar depuración

Después de eso, el script se aplicará al gráfico de tiempo en el terminal de trading, y en el diario de los Expertos aparecerá el resultado de trabajo del script — entrada "Hello World!!!":

Depuración del script

Para finalizar la depuración, hay que ejecutar el comando "Detener la depuración Detener la depuración" en el menú "Depurar".

Una vez pasados todos los pasos, se puede utilizar el script en el terminal de trading. Para abrirlo, ejecute el comando "Terminal de trading Terminal de trading" en el menú "Herramientas" o pulse la tecla "F4".