MetaTrader 5のヘルプ

定形チャートとプロファイル

定型チャートとは、他のチャートに適用することができる、チャートウィンドウパラメータのセットです。以下のデータは、定型チャートに保存することができます。

  • チャートの種類と色;
  • 基本配色
  • チャートスケール
  • OHLC線表示の有効化/無効化
  • エキスパートアドバイザーとパラメータの実行
  • 適応されたカスタム及びテクニカル指標と設定
  • グラフィックオブジェクト
  • 日の区切り

チャートに定型チャートを適用すると、定型チャートに保存された設定が金融製品や時間枠に適用されます。例えば、MACD、RSI、及び移動平均指標を含む定型チャートを作成し、その後、他のチャートで使用することができます。この場合、異なるシンボルと期間を持つチャートウィンドウの外観が統一されます。

定型チャートは TPLファイルとして\MQL5\Profiles\Templates フォルダに保存されています。プラットフォームは、事前定義された定型チャートのいくつかを提供しています。

  • default.tpl — 新しいチャートを作成するときに自動的に適用される基本的な定型チャート
  • tester.tplテスト結果を表示する為の定型チャート
  • debug.tpl — MQL5アプリケーションのデバグを MetaEditorから始めたときに作成される定型チャート

必要なパラメータを持つ定型チャートを作成(または既存のものを変更)するには、チャートを設定して、コンテクストメニューの「定型チャートの保存...定形チャートの保存...」をクリックします。

プラットフォーム間でテンプレートやプロファイルを共有および同期するには、MetaEditorに統合されたMQL5ストレージを使用します。MQL5.communityアカウントを使用して、どのコンピュータからでもアクセスできます。

定型チャートアクション

チャート設定メニュー、チャートコンテクストメニュー、またはツールバーで「定型チャート定型チャートメニュー」をクリックします。

定型チャートメニュー

定型チャートアクション

定型チャートメニュー

  • 作成
    定型チャートの保存...定型チャートの保存...」をクリックします。アクティブチャートウィンドウの情報に基づいて新しい定型チャートが作成されます。
  • 変更
    定型チャートの編集には同じステップに従いますが、新しいファイル名の代わりに既存する定型チャート名を選択します。
  • 適応
    定型チャートをチャートに適応するには、メニューの下部で必要なファイルを選択するか、「定型チャートの読み込み...」をクリックして任意のフォルダにある定型チャートを開きます。
  • 削除
    定型チャートを削除するにはチャート設定メニューかチャートのコンテクストメニューで「定型チャートの作成」をクリックします。

プロファイル

プロファイルは、チャートグループの作業を便利にします。以下のデータは、プロファイルに保存することができます。

  • プロファイルが保存された時点で開いているチャート
  • それらの位置とサイズ
  • チャートに適応された定型チャート

プロファイルが開かれると、各チャートは、プロファイルが保存された際と同じそれぞれの位置に正確に配置されています。開いているチャートウィンドウ内のすべての変更は自動的に現在のプロファイルに保存されます。現在のプロファイ—ルのチャートリストはウィンドウメニューで見られます。現在のプロファイルの名前はステータスバーで表示され、プロファイルコントロールメニューでティックでマークされています。

デフォルトのプロファイルは、プラットフォームのインストール時に作成されます。最初は、基本的な EURUSD、USDCHF、GBPUSD 及び USDJPY4通貨ペアの チャートウィンドウが格納されています。: プロファイルは \MQL5\Profiles\Charts フォルダで保存されています。

プロファイルには実行中のエキスパートアドバイザーでを含む定型チャートも保存されています、よってプラットフォーム設定にはプロファイルの保存時に自動的にエキスパートアドバイザーを停止する選択肢があります。

プロファイルの管理

ファイルメニュー、ツールバーのボタンで「チャートのプロファイル「チャートのプロファイル」メニュー」をクリックします。現在のプロファイルの名前をステータスバーでクリックしてもいいです。

「チャートのプロファイル」メニュー

コマンド

「チャートのプロファイル」メニュー

  • — リスト中の次のプロファイルに切り替えます。「Ctrl+F5」キーを押しても同じことができます。
  • — リスト中の前のプロファイルに切り替えます。「Shift+F5」キーを押しても同じことができます。
  • 名前を付けて保存... 名前を付けて保存... — 現在のプロファイルに新しい名前を付けて保存します。新しいプロファイルは、現在のプロファイルのコピーで、保存した後にアクティブになります。
  • 消去 — プロファイルを消去します。このコマンドをクリックすると、既存のプロファイルのメニューが表示されます。それらのいずれかを選択し手削除します。

このメニューの下部には、既存のプロファイルのリストが含まれています。そのうちの一つを適用するには、それをクリックします。

事前定義されたプロファイルは、取引口座に割り当てることができます。口座番号と同じ名前のプロファイルを作成します。この事前定義されたプロファイルは、この口座に切り替えると自動的に適用されます。事前定義されたプロファイルが存在しない場合は、現在のプロファイルがアクティブのままになります。

現在のプロファイルと(Default としてマークされている)デフォルトのプロファイルを削除することはできません。